Angular 7.2.1 CLI 发布,支持TypeScript 3.2 和 Angular 7.2.0-rc.0
2019/01/11 10:21:32 来源:Linux公社 作者:醉落红尘

今天,Google Angular团队的工程师Minko Gechev宣布发布Angular CLI 7.2.1。 此版本修复了webpack-dev-server漏洞,并且还支持多选列表提示,TypeScript 3.2和Angular 7.2.0-rc.0。

关于webpack-dev-server漏洞

npm install命令显示了Missing Origin Validation漏洞,因为3.1.10之前的webpack-dev-server版本缺少websocket服务器上的原始验证。远程攻击者可以利用此漏洞窃取开发人员的代码,因为用于热模块替换(HMR)的websocket服务器的请求来源未经过验证。

Angular 7.2.1 CLI中的其他更新

Angular CLI的GitHub存储库的发行说明中列出了一些更新和错误修复。他们之中有一些是:

Ubuntu 15.04下Angular 2的安装与使用  https://www.linuxidc.com/Linux/2017-05/144268.htm

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2019-01/156294.htm


10

本栏最新