数据库升级后报ORA-06550、PLS-00306问题解决
2019/09/17 19:17:50 来源:Linux社区 作者:零度的雨1205

平台:Windows

原库版本:Oracle 11.2.0.1

新库版本:Oracle 11.2.0.4

升级方式:软件升级

通过软件升级到11.2.0.4后,当查询的语句涉及到较多的blob、clob字段时,会报ORA-06550 、PLS-00306:调用'SYNCRN'时参数个数或类型错误,该问题是一个bug问题,可以通过如下方法解决:

用plsql登录数据库,然后完成以下两步,注意两步内容要求在同一个窗口下完成:

(1)alter session set current_schema=CTXSYS;

(2)重新编译以下存储过程:

create or replace procedure syncrn (

ownid IN binary_integer,

oname IN varchar2,

idxid IN binary_integer,

ixpid IN binary_integer,

rtabnm IN varchar2,

srcflg IN binary_integer,

smallr IN binary_integer

)

authid definer

as external

name "comt_cb"

library dr$lib

with context

parameters(

context,

ownid ub4,

oname OCISTRING,

idxid ub4,

ixpid ub4,

rtabnm OCISTRING,

srcflg ub1,

smallr ub1

);

/

以上步骤完成后,即可解决该报错问题。

更多Oracle相关信息见Oracle 专题页面 https://www.linuxidc.com/topicnews.aspx?tid=12

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2019-09/160693.htm


7

本栏最新