CVE-2020-1967:OpenSSL拒绝服务漏洞警报
2020/04/22 21:01:08 来源:Linux公社 作者:醉落红尘

最近,openssl正式发布了TLS 1.3组件拒绝服务漏洞的风险通知,漏洞编号为CVE-2020-1967,且漏洞级别为高风险。

OpenSSL是用于应用程序的软件库,可保护计算机网络上的通信免遭窃听或需要识别另一方的身份。它被Internet服务器广泛使用,包括大多数HTTPS网站。 TLS(传输层安全性)是一种安全协议,其目的是为Internet通信提供安全性和数据完整性保证。该协议在浏览器,电子邮件,即时消息,VoIP和Internet传真等应用程序中得到广泛支持。该协议现已成为Internet上安全通信的行业标准。

openssl中存在一个拒绝服务漏洞。攻击者可以发送特制的请求数据包,以使目标主机服务崩溃或拒绝服务。

漏洞详情

“在TLS 1.3握手期间或之后调用SSL_check_chain()函数的服务器或客户端应用程序可能会由于对NULL指针的取消引用而导致崩溃,这是由于对'signature_algorithms_cert'TLS扩展的不正确处理导致的,”阅读OpenSSL项目发布的建议。

“如果从对等方收到无效或无法识别的签名算法,则会发生崩溃。恶意对等方可以在拒绝服务攻击中利用此漏洞。”

受影响的版本

解决方法:

升级到1.1.1g版本

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2020-04/163000.htm


8

本栏最新